You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
To make a case for this ticket, many libraries are now requiring protobuf>4. Meaning that tensorflow-metadata is blocking codebases from upgrading all these other libraries.
Reacted by Neil Girdhar, corey hu, Matt, Leo Gallucci, Mason Kirchner and Ryan C
it looks like this is holding us back from upgrading to tensorflow 2.12.0 and using protobuf 4 for any use case that requires tensorflow-metadata, or tensorflow-datasets which requires tensorflow-metadata
Reacted by Neil Girdhar, corey hu, Matt, Leo Gallucci, James Myatt and Jeff Picard
EDIT: If you could publish any changes that loosen the Protobuf dependency as tensorflow-metadata==1.14.1 that would be appreciated. A 1.15.0 release with the loosened Protobuf dependency would be worthless without re-releasing all the Tensorflow libraries that depend on tensorflow-metadata because they're all scoped to tensorflow-metadata<1.15.0.
@NeilGirdhar Hi. I see that 'protobuf>=3.20.3,<4.21' has been used for 1.14.0. Can you please explain or provide more details on why this is not sufficient?
@rtg0795 I'll let others comment more on this, but if I remember, this was preventing upgrades to Python 3.12. See also: #37 (comment) and #37 (comment)
Is this fixed on master? The boundary is still <4.21, which does not include any valid protobuf 4 versions. This is impacting my organization as well. We have packages that depend on protobuf >4, and the current boundary does not provide that.
Note: This is for Py39/310, the newer protobuf versions are supported for py311, but note even TFX supports 311 yet/we will probably need 39/310 support for a while anyways
As the previous commenter mentioned, the most simplistic way to fix the dependency issue is to jump to Python 3.11 to allow tensorflow-metadata package work with the latest version of Protobuff:
Activity
chhabrakadabra commentedon Sep 30, 2022
To make a case for this ticket, many libraries are now requiring
protobuf>4. Meaning that tensorflow-metadata is blocking codebases from upgrading all these other libraries.Generate requirements files.
feat: BigTable online store (#3140)
feat: BigTable online store (feast-dev#3140)
mattb-zip commentedon Mar 31, 2023
it looks like this is holding us back from upgrading to
tensorflow 2.12.0and usingprotobuf 4for any use case that requirestensorflow-metadata, ortensorflow-datasetswhich requirestensorflow-metadatacoreyhu commentedon Apr 4, 2023
any word on this?
elgalu commentedon Oct 4, 2023
any updates?
NeilGirdhar commentedon Nov 3, 2023
@rtg0795 Would you mind taking a look at this?
masonkirchner commentedon Nov 27, 2023
Any updates on this?
EDIT: If you could publish any changes that loosen the Protobuf dependency as tensorflow-metadata==1.14.1 that would be appreciated. A 1.15.0 release with the loosened Protobuf dependency would be worthless without re-releasing all the Tensorflow libraries that depend on tensorflow-metadata because they're all scoped to tensorflow-metadata<1.15.0.
rtg0795 commentedon Jan 2, 2024
@NeilGirdhar Hi. I see that 'protobuf>=3.20.3,<4.21' has been used for 1.14.0. Can you please explain or provide more details on why this is not sufficient?
NeilGirdhar commentedon Jan 3, 2024
@rtg0795 I'll let others comment more on this, but if I remember, this was preventing upgrades to Python 3.12. See also: #37 (comment) and #37 (comment)
NeilGirdhar commentedon Feb 11, 2024
@rtg0795 What are your thoughts? It's been almost two years since this was requested.
jeffpicard commentedon Mar 13, 2024
@rtg0795
protobuf>=3.20.3,<4.21is not sufficient because 4.21 is the first released 4.x version.This is blocking us as well.
NeilGirdhar commentedon Mar 15, 2024
Thank you for fixing this on master! For everyone watching this, we just need to wait for the next release or use the master version.
Also, just noting that Protobuf 5 is now out 😄
rclough commentedon Aug 16, 2024
Is this fixed on master? The boundary is still <4.21, which does not include any valid protobuf 4 versions. This is impacting my organization as well. We have packages that depend on protobuf >4, and the current boundary does not provide that.
Note: This is for Py39/310, the newer protobuf versions are supported for py311, but note even TFX supports 311 yet/we will probably need 39/310 support for a while anyways
dbalabka commentedon Nov 28, 2024
As the previous commenter mentioned, the most simplistic way to fix the dependency issue is to jump to Python 3.11 to allow
tensorflow-metadatapackage work with the latest version of Protobuff:metadata/setup.py
Lines 132 to 133 in f440b43
It worked for me. Thanks to @rclough