Skip to content

About

Various SIP resources.

Resources

Stars

260 stars

Watchers

17 watching

Forks

Latest commit

 

History

73 Commits

Folders and files

NameName
Last commit message
Last commit date
 
 
 
 
 
 

Repository files navigation

SIP Resources

An incomplete list with various useful SIP resources, mostly open source, but not only.

Markers:

  • ⭐ - open source
  • ⚑ - freeware
  • πŸ’° - paid component

Index

Standard Specifications

SIP Core

  • RFC3261 : SIP: Session Initiation Protocol
  • RFC3262 : Reliability of Provisional Responses in the Session Initiation Protocol (SIP)
  • RFC3263 : Session Initiation Protocol (SIP): Locating SIP Servers
  • RFC3265 : Session Initiation Protocol (SIP)-Specific Event Notification

SDP

  • RFC8866 : SDP: Session Description Protocol
  • RFC4566 : SDP: Session Description Protocol (obsoleted)
  • RFC3264 : An Offer/Answer Model with the Session Description Protocol (SDP)

Online Tutorials

Books

Network Tools

SIP Servers

SIP Softphones

SIP GUI Softphones

SIP softphones with graphical user interface:

SIP CLI Softphones

SIP softphones with command line interface:

SIP WebRTC Softphones

SIP softphones running on web browser based on WebRTC standards:

SIP Hardphones

  • AudioCodes
  • Avaya
  • Cisco (Linksys, Sipura)
  • Fanvil
  • Gigaset (Siemens)
  • Grandstream
  • HTech
  • Panasonic
  • Poly (Polycom, Obihai)
  • Mitel (Aastra)
  • Panasonic
  • Sangoma (Digium)
  • Snom
  • Tiptel
  • Ubiquiti
  • VTech
  • Yealink

SIP Libraries

SIP Native Libraries

SIP libraries written in C, C++, Java, Go, Rust, Python, PHP, Erlang, ...:

SIP JavaScript Libraries

SIP libraries written in JavaScript:

SIP Command Line Tools

RTP Relays

Telephony Operator Systems

Fixed Network Telephony

Mobile Network Telephony

Telephony API Platforms

PBX Systems

PBX Add-ons

  • IVR Studio ⭐ πŸ’° - FreePBX module to generate professional IVR audio with neural Text-to-Speech
  • QueueMetrics πŸ’° - Contact-centre monitoring and reporting, works with most Asterisk and FreeSwitch based systems.
  • VoiceOI πŸ’° - No-code outbound AI voice bots for call centers: they log in to VICIdial as remote agents or dial through any SIP carrier, and live-transfer qualified callers.

Session Border Controllers

Billing And Rating

SIP Frameworks

  • SIP-Lab ⭐ - a node module that helps to write SIP functional tests

Log Management Tools

SIP-Related Add-Ons

RTC Events

About

Various SIP resources.

Resources

Stars

260 stars

Watchers

17 watching

Forks

Releases

Sponsor this project

Packages

Used by

Contributors